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Chapter -1 

Creating HTML Forms using KompoZer 
--------------------------------------------------------------------------------- 

 
1. In HTML,  Forms are used to help the visitors of the website to input data. 

a) Forms  b) links  c) Images  d) Tables 

 
2. The ……………tag is used to implement all elements in HTML form. 

a) <form> … </form>   b) <html>…..</html>   
c)  <input> …..</input>   d) <body> …</body> 

 

3. Form element uses …………types of  attributes. 
      a)  Action   b)  Method  c) Name  d) All of above 
 

4. The ………………….attribute specifies the HTTP method to be used when sending 
the data.  

a) Method  b) Action  c) Name  d) All of above 
 

5. In form, Method attribute can take……….. values. 

a) GET    b)  POST  c) SET  d) Both a and b 
 

6. Which method retrieves the data from the form and sends it to the server by 

attaching it at the end of the URL? 
a) GET    b)  POST  c) SET  d) Both a and b 

 
7. In the……………method, the data is sent as a block through the HTTP transaction. 

a) GET    b)  POST  c) SET  d) Both a and b 

 
8. The ……….. method does not have any restrictions on data length. 

a) GET    b)  POST  c) SET  d) Both a and b 
 

9. The default value for method attribute in the form is ……………….. 

a) GET    b)  POST  c) SET  d) Both a and b 
 

10. If the form submission is active like modifying a server side database, our form 

must use the ……………. method. 
a) GET    b)  POST  c) SET  d) Both a and b 

 
11. If the form submission is passive, such as a search engine query, then we may 

use the …….. method. 

a) GET    b)  POST  c) SET  d) Both a and b 
 

12. The ………..elements are used to insert various fields like radio button, textbox 
etc in the form. 

a) Input   b) <form>  c) <body>  d) <html> 

 
13. The ………tag  is used to implement Input control element. 

a) <input>….</input>  b) <html> ….</html> 

c)  <form>….</form>   d)  <select>…</select> 
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14. Which  attribute of the input element specifies the field that is to be created in the 

form? 
a) Type   b) Name  c) Value  d) Maxlength 

 
15. Which  attribute specifies the name to be used for the field in the form? 

a) Type   b) Name  c) Value  d) Maxlength 

 
16. Which  attribute specifies the default value of the field in the form? 

a) Type   b) Name  c) Value  d) Maxlength 
 

17. The value attribute defines the text that will be displayed in the web browser 

within text field when it is initially loaded. 
a) Type   b) Name  c) Value  d) Maxlength 

 

18. ………… field type  is used to enter text in the form. 
a) Text   b) Password  c) Radio buttons d) Checkbox 

 
19. …………. field type,  character typed is converted into non readable format. 

a) Text   b) Password c) Radio buttons d) Checkbox 

 
20. The…………input field usually takes the form of a text input box followed by a 

browser button. 

a) Text   b) Password  c) File   d) Checkbox 
 

21. ……………….are used for selecting one item from multiple available choices. 
a) Text   b) Password  c) Radio buttons d) Checkbox 

 

22. Generally …………….are used to select a single item from a given group of items. 
a) Text   b) Password  c) Radio buttons d) Checkbox 

 
23. The name of a group must be………… in multiple choice selection fields like radio 

button, selection list, checkbox. 

a) Same   b) unique  c) proper  d) admin 
  

24. When a …………..is used, it places on the page a square and it is marked with a 

check mark or tick mark appearing when the box is selected. 
a) Text   b) Password  c) Radio buttons d) Checkbox 

 
25. The ………..tag  is used to create a drop down menu or select list field. 

a) <select> … </select>  b) <option>……</option> 

c) <form>…..</form>   d) None of above 
 

26. The tag ……………. is used to create the elements within the select list field. 
a) <select> … </select>   b) <option>……</option> 
c)  <form>…..</form>   d) None of above 

 
27. If we want to make a option selected by default in list field, we can add 

............attribute to the <option> tag. 

a) Selected  b) Checked  c) Clicked  d) initially selected  
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28. The user can select more than one option by pressing ………..in pull down menu. 

a) Ctrl    b) clicking  c) double clicking  d) both a and b 
 

29. The ……………element allows multi-line text input. 
a) Textarea b) Text  c) File   d) select 

 

30. The tag ……… is used to implement textarea element or comment box or multiple 
line text box. 

a) <textarea> … </textarea>   b) <text>…..</text> 
c) <input> …….</input>    d) <select>…..</select> 

 

31. The ……….element can be used to enter comment, report or a long description of 
product. 

a) Textarea  b) Text  c) File   d) select 

 
32. The size of a textarea element can be specified using …………….. attribute. 

a) Rows   b) Cols  c) table  d) Both a and b 
 

33. In the Textarea, if input exceeds the visible area, a ……….bar appears 

immediately.  
a) Scroll   b) Status  c) Title   d) Menu 

 

34. If user wants to reset all the values to their default value or blank into the form, 
then…………. button is used. 

a) Submit  b) Reset  c) Login  d) Resend 
  

35. …………… button is used to submit the values of form. 

a) Submit  b) Reset  c) Login  d) Resend 
 

36. The form handling programs may be written in……….technology. 
a) CGI   b)  ASP  c)  PHP  d) All of above 

 

37. ……... is a software application that provides complete facilities to programmer to 
develop software. 

a) IDE   b) web browser c) App  d) CGI 

 
38. …………….is a free open source web development IDE software. 

a) KompoZer  b) Front page c) HTML  d) PHP 
 

39. ………… is a complete web authoring system which integrates web page 

development and web file management.  
a) KompoZer  b) Front page c) HTML  d) PHP 

 
40. A ……………… gives rapid access to the files on both local machines and remote 

servers. 

a) Site Manager b) Web Manager c) Web server d) Work station 
 

41. To view the different tool bars and status bar click on ………… 

a) View → Show / Hide  b)  Format  Show/Hide  
c) Edit  Show / Hide     d) none 
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42. In KompoZer, below the menu bar there are………… tool-bars. 

a) Composition  b)  Format Toolbar1   
c)  Format Toolbar2  d) All of above 

 
43. Which toolbar is used to create a new file, open a file, save a file or publish a web 

page in Kompozer? 

a) Composition  b)  Format Toolbar1       
c)  Format Toolbar2  d) All of above 

44. The … ……toolbar are used to format the text, add bullets, numbering and 
perform similar formatting operations. 

a) Composition  b)  Format Toolbar1   

c)  Format Toolbar2  d) Both b and c 
 

45. In the center of KompoZer window, there are ……………... panes. 

a) Site Manager   b) blank web page  
c) Composition   d) both a and b   

46. ………………..is a powerful tool used to navigate within the site or between the 
sites. 

a) Site Manager  b) Web Manager  

c) Web server   d) Work station 
 

47. Edit mode toolbar have ………….. viewing mode in Kompozer. 

a) Normal  b)  HTML tags  c)  preview   d) All of above 
 

48.  The ……………….mode offers the page view as seen in a browser. 
a) Normal  b)  HTML tags  c)  preview   d) All of above 

 

49. The links does not operate in …………mode. 
a) Normal  b)  HTML tags  c)  preview   d) All of above 

 
50. In ……………….mode the table outlines are visible. 

a) Normal  b)  HTML tags  c)  preview   d) All of above 

 
51. The……………….. view is similar to preview mode. 

a) Normal  b)  HTML tags  c)  preview   d) All of above 

 
52. In KompoZer, the ………………….tab is used to design the web page. 

a) Split   b) Design  c) Source   d) All of above 
 

53. In KompoZer, the …………. tab displays the HTML source of the current element. 

a) Split   b) Design  c) Source   d) All of above 
 

54. In KompoZer, …………… tab helps user in editing of source code of a web page. 
a) Split   b) Design  c) Source   d) All of above 

 

55. In KompoZer when we click File → New, a dialog box appears with …………..title. 
a) Create a new document or template b) new document 
c) design document     d) Template 
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56. To Create a form in KompoZer, ……………………menu - option is used. 

a) Insert → Form → Define Form  b) Form  Define form 
c)  Insert  Define form    d) Define form 

 
57. In ………………tab of form properties dialog box, enter the file name where you 

want the form data to be submitted. 

a) Name   b) Action URL c) Method   d) Form 
 

58. In working area of KompoZer, form inserted with ………..colored outline in the 
untitled page. 

a) Black   b) light blue c) light red   d) light green 

 
59. In KompoZer, all the form elements will be placed within the  …………..dotted box. 

a) Blue   b) Red  c) Green   d) Orange 

 
60. To insert any form fields like textbox, password box, file selection box, check box, 

radio button, submit and reset buttons,  click on ……………….menu – option in 
Kompozer. 

a) Insert → Form → Form field  b) Insert  Form field 

c) Form   Form filed   d) Format  Form Field 
 

61. ………..option is selected in form field dialog box, if we want to add advance 

properties to our field. 
a) More Properties  b) Properties c) Advanced Properties d) None 

 
62. If you want to show some text before the user actually enters data, then Enter 

some text in the …………….textbox of form field dialog box. 

a) Initial Value  b) Value  c) default value d) proper value 
 

63. At the time of file saving, to give a proper title of your web page, ………….. dialog 
box is used. 

a) File name  b) Page Title c) Page Name  d) Name 

 
64. To save the KompoZer or HTML file,  with……….. extension. 

a) .htm   b) .html  c) .HTML  d) Both a and b 

 
65. The home page that will open when user type the website's URL, the page save 

with the name ……... 
a) index.html  b) home.html c) untitled.html  d) *.html 

 

66. The …………….option is the attribute of Radio button and check-box fields when 
the user wants to select by default value in the form. 

a) Selected  b) Checked     c) Initially Selected d) value selected 
b)  

67. When we create the radio buttons within a group, the group name must be 

the……… for all the possible answers. 
a) Same   b) unique  c) proper   d) public 
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68. In KompoZer, to insert the drop down or list field,  use …………….Menu - option. 
a) Form → Selection List  b) Insert  Form   Form  Field 

c) Format  Form field  d) Edit  Selection List 
 

69. To insert the list member into the drop down or list field click on …………Button 
of selection list dialog box. 

a) Add Option  b) + option  c) Click option  d) Select option 

 
70. In KompoZer, to give a background color to the form select…………menu - option. 

a) Format → Background  b) Format → Page Colors and Background 
c) Format  Page Colors  d) Insert  Background 

 

71. To open KompoZer click on ………..menu – option. 
a) Application → Programming → KompoZer  b) Application  KompoZer 
c)  Application → Internet → KompoZer   d) Both a and c 

 
72. When any item in page is clicked, on which place its structure will appear? 

     a) Status Bar  b) Title bar  c) Menu bar  d) Format bar 
 

73. What is the default form name in KompoZer? 

    a) Untitled   b) Document. c) index  d) All of above 
 

74. What is the use of type attribute? 

  a) To specify the field that is to be created   
  b) To specify the name to be used. 

 
75. What is the use of name attribute? 
  a) To specify the field that is to be created   

 b) To specify the name to be used. 
 

76. What is used to accept the data over the web? 
 a) CSS    b) Form  c) Link   d) Table 
 

77. What is the default  field to create a form? 
 a) Textbox   b) Submit Button     c) File selection   d) Reset button 
 

78. Which option is used in KompoZer to insert the textarea field? 
a) Form → Text Area  

b) Form → Form Field → Text Area. 
 

79. Which option is used in KompoZer to insert the label? 

a) Form → Form Field → Define Label  b) Form → Define Label 
c) Form  Define form  Label   d) Form  Label 

 
80. Which label will be seen at the bottom of “file → new” dialog box? 

a) Create in   b) Insert on  c) Create  d) Define in 

 
81. In which view the form are shown surrounded blue dotted box? 

a) Normal view   b) Preview  c) HTML Tags d) Source 
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82. All three modes of KompoZer provides which facility? 
a) Editing    b) Scrolling  c) Design  d) Insert 

 
83. Which shows a blank untitled web page? 

a) Site Manager   b) Page Pane c) Slide Pane d) Page Source 
 

84. What is the short cut key to close site manager? 

a) F5     b) F9   c) F7   d) F11 
 

85. In which mode the script do not run? 
a) Preview    b) Design  c) HTML Tags d) Source 
 

86. In “HTML Tag view” which color marker is used to indicate the start tag for all 
elements? 
a) Yellow    b) Blue.  c) Orange  d) Green 

 
87. In KompoZer which tab shown all details of the HTML code? 

a) Split Tab    b) Source Tab c) HTML Tags d) Normal 
 

88. What is the URL address to download  KompoZer? 

a) www.KompoZer.net  b) www.KompoZer.co.in c) Kompozer.in d) None 
 

89. Which are the Open Source IDE softwares? 

a)  KompoZer  b)  Eclipse, Jbuilder  c) Netbeans. d) All of above 
 

90. What is provides by an IDE? 
a) GUI, Text or code editor b)  a compiler and /or interpreter    
c) a debugger   d) All of above 

 
91. A radio button input shows in which shape? 

a) A circle with a dot inside   b) A square with a tick mark. 
a) A Circle     d) Square 
 

92. To avoid which type of error in the password entry, it is advisable to ask the user 
to confirm password. 
a) System   b) Typographic c) Debugging  d) Display 

 
93. Which form's attribute takes a file name as value? 

a) Action    b) Method  c) Name  d) Size 
 

94. Which allow more interactivity and control data entry to user? 

a) Form    b) Script  c) Link  d) Table 
 

 
 

 
 

 
 

http://www.kompozer.net/
http://www.kompozer.co.in/
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Text book Exercise 
 

1. Which of the following is a container used to collect different kinds of inputs from 

the user? 

a) Form  b) Webpage  c) Text   d) Input 

2. Which of the following element is used to create  an HTML form.? 

a) Textarea b) Form  c) Select and option d) Input 

3. Which of the following is the  tag used to implement form element? 

a) <form> …</form> b) <form> …<form>  

c) </form>…</form>  d) <frm>…</frm> 

4. Which of the following attribute of form is used to specify where to send the form 

data when the form is submitted? 

a) Method  b) action  c) submit  d) input 

5. Which of the following attribute of form specifies the HTTP method to be used 

when sending the data? 

a) Submit  b) action  c) method  d) input 

6. Which of the following  values are used by method attribute? 

a) GET and POST b) GET and SET c) GET and PUT d) SET and POST 

7. Which of the following method allows only a limited amount of information to be 

sent at a time? 

a) GET   b) POST  c) SET  d) PUT 

8. Which of the following method sends the data as a block through the HTTP 

transaction? 

a) GET   b) SET  c) PUT  d) POST 

9. Which of the following attribute of the input element specifies field that is to be 

created in the form? 

a) Input   b) Type  c) Name   d) Value 

10. Which of the following element allows multi- line text input? 

a) Textarea  b) Input  c) Select and option d) Form 

11. Which of the following element is used to create a drop down list or menu in a 

form? 

a) Input  b) Textarea  c) Select    d) Form 

12. Which of the following is a free open source web development IDE? 

a) HTML  b) Kompozer  c) Scite   d) Base 
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13. Which of the following  stands for “WYSIWYG”? 

a) When You See Is When You Get b) What You See Is When You Get 

      c) What You See Is What You Get d) When You See Is What You Get 

 

Full Forms:- 

1. IDE → Integrated Development Environment. 

2. GUI → Graphical User Interface. 
3. CSS → Cascading Style Sheet. 

 


